Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; PDOXpander has a deprecated constructor in /usr/home/void/domains/programowo.net/public_html/core/PDOXpander.class.php on line 11 Debian, python i problemy z instalacją cryptography - Programowo.net

Debian, python i problemy z instalacją cryptography

Data publikacji: 2015-03-31 | Tagi:

Ostatnio trafił mi się problem z instalacją pakietu cryptography, który został pociągnięty przez pip przy instalacji PyOpenSSL.

Notuję rozwiązanie, żeby i mi, i Wam nie umknęło ;)

Konkretnie chodzi o błąd o treści:

distutils.errors.DistutilsError: Setup script exited with error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

Problem jest z gatunku tych banalnych, ale trudnych do uchwycenia i sprowadza się do sprawdzenia, czy mamy zainstalowane paczki: python-dev, libssl-dev oraz libffi-dev. W moim wypadku brakowało tej ostatniej.

Zatem aby zainstalować brakujące paczki wydajemy polecenie:

sudo apt-get install python-dev libssl-dev libffi-dev


Oceń ten post:
Podziel się:

comments powered by Disqus

IT w obrazkach: